[rspec-users] Nokogiri 1.1.0 and ActiveRecord 2.2.0

aslak hellesoy aslak.hellesoy at gmail.com
Thu Dec 25 13:37:29 EST 2008


On Thu, Dec 25, 2008 at 5:42 PM, James Byrne <lists at ruby-forum.com> wrote:

> Manasi Vora wrote:
> >
> > I tried this but I get the following error now -
> > C:\ruby_on_rails\sample>rake features
> > (in C:/ruby_on_rails/sample)
> > c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> > `gem_original_re
> > quire': no such file to load -- webrat/rspec-rails (MissingSourceFile)
> > Failed to load features/support/env.rb  from
> > c:/ruby/lib/ruby/site_ruby/1.8/ruby
> > gems/custom_require.rb:31:in `require'
> >
> > I have nokogiri 1.0.7 and webrat 0.3.2 with cucumber 0.1.12
> >
> > Thoughts ?
>
> As shipped, cucmber expects to have rspec and rspec-rails available,
> either as plugins or as gems.  Install both and try again.
>

Cucumber is decoupled from RSpec and does not depend on it. However, the
default setup when Cucumber is used with Rails is to use Webrat and RSpec,
but you can change this.

Aslak


>
> HTH
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20081225/b30275dc/attachment.html>


More information about the rspec-users mailing list