[rspec-users] Nokogiri 1.1.0 and ActiveRecord 2.2.0

James Byrne lists at ruby-forum.com
Wed Dec 24 09:58:45 EST 2008


Just a heads up.  I updated my nokogiri gem to 1.1.0 yesterday and could
not run rake features thereafter.  I had to drop back to 1.0.7. I have
reported this problem on the project page at rubyforge.

This is what I see:

 /usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:442:in
`load_missing_constant': uninitialized constant Nokogiri::CSS::XML
(NameError)
        from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:77:in
`const_missing'
        from
/usr/lib/ruby/gems/1.8/gems/nokogiri-1.1.0/lib/nokogiri/css/selector_handler.rb:3
        from
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list