[rspec-users] newbie: errors getting started with cucumber

Mischa Fierer f.mischa at gmail.com
Sun Dec 21 00:09:21 EST 2008


Try pasting this into config/environments/test.rb

#config/environments/test.rb
#config.gem 'rspec-rails', :source => "http://gems.github.com", :lib =>
'spec/rails'
#config.gem 'cucumber', :version => '0.1.12', :source => "
http://gems.github.com"
config.gem 'webrat' , :source => "http://gems.github.com"
#config.gem 'nokogiri' , :source => "http://gems.github.com"

Example cucumber apps here:
http://github.com/bmabey/email-spec/tree/master/spec/rails_root

And here:
http://github.com/qrush/cucumber_seeds/tree/master


On Sat, Dec 20, 2008 at 8:42 PM, Sarah Allen <lists at ruby-forum.com> wrote:

> Just getting started with Ruby and Rails, I wanted to check out BDD and
> cucumber seemed like a good place to start.  Let me know if this stuff
> is too new for a newbie and I'll wander off.
>
> I've installed the following:
>   sudo gem install cucumber
>   sudo gem install rspec rspec-rails webrat
>
> $ rake features
> (in /Library/WebServer/Documents/todolist)
> /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require': no such file to load -- webrat/rspec-rails
> (MissingSourceFile)
> Failed to load features/support/env.rb  from
> /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
>  from
>
> /Library/Ruby/Gems/1.8/gems/activesupport-2.2.2/lib/active_support/dependencies.rb:155:in
> `require'
>  from ./features/support/env.rb:12
>  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require'
>  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
>  from
>
> /Users/sarah/.gem/ruby/1.8/gems/cucumber-0.1.13/bin/../lib/cucumber/cli.rb:230:in
> `require_files'
>  from
>
> /Users/sarah/.gem/ruby/1.8/gems/cucumber-0.1.13/bin/../lib/cucumber/cli.rb:228:in
> `each'
>  from
>
> /Users/sarah/.gem/ruby/1.8/gems/cucumber-0.1.13/bin/../lib/cucumber/cli.rb:228:in
> `require_files'
>  from
>
> /Users/sarah/.gem/ruby/1.8/gems/cucumber-0.1.13/bin/../lib/cucumber/cli.rb:152:in
> `execute!'
>  from
>
> /Users/sarah/.gem/ruby/1.8/gems/cucumber-0.1.13/bin/../lib/cucumber/cli.rb:13:in
> `execute'
>  from /Users/sarah/.gem/ruby/1.8/gems/cucumber-0.1.13/bin/cucumber:6
> rake aborted!
>
> I even tried installing webrat as a plugin which seemed to be a solution
> proposed in a previous post:
>   script/plugin install git://github.com/brynary/webrat.git
>
> but in either case I see the same errors.
>
> I'm on Mac OS 10.5.6 if that matters.
>
> Thanks in advance,
>
> Sarah
> home: www.ultrasaurus.com
> code: www.ultrasaurus.com/code
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/rspec-users/attachments/20081220/43afbd47/attachment.html>


More information about the rspec-users mailing list