[rspec-users] Upgraded to 2.1 and 1.1.4 from 2.0 and 1.1.3, no output from 'rake spec'

Pat Parslow lists at ruby-forum.com
Sun Aug 24 07:36:36 EDT 2008

Pat Parslow wrote:
> I am getting the same problem on XP with a fresh install (ruby 1.8.6 
> patch 111 - not so fresh, I admit) Rails 2.1 rspec 1.1.4
> I think the problem may be something to do with not being able to check 
> out the rspec 1.4.1 after cloning the git.  It complains that:
> error: You have local changes to 
> 'examples/stories/game-of-life/behaviour/storie
> s/CellsWithMoreThanThreeNeighboursDie.story'; cannot switch branches.
> which is rich as I just downloaded it and haven't changed anything :-)
>> Any ideas?  I ran "script/generate rspec" and let it overwrite 
>> everything.
> Ditto...

OK, so it wasn't that.  I did a git pull and then checked-out 1.1.4 and 
it still behaved the same way (but it might be nice to tell people that 
the git clone they get might need updating before it can be checked out 
- I am trying to work that one out still)

It occurred to me that I had the rspec gem installed (this will at least 
partly give the chance to have a laugh at me...) so I tried putting a
 require 'rubygems'
in script\spec.  Voila, I can now run single tests using
 ruby script\spec path\to\spec
with success.  However,
 rake spec
still does nothing (well, nothing visible)
The odd thing is, as I was typing this, it occurred to me I had removed 
the rspec gem when trying to get the plugin to work.  So I checked, and, 
sure enough, no rspec gem.

I think I must be a bear of very little brain, because I cannot for the 
life of me work out what is going on!
Posted via http://www.ruby-forum.com/.

More information about the rspec-users mailing list