[rspec-users] rake spec loads development environment

Jonathan Linowes jonathan at parkerhill.com
Tue Aug 19 16:10:14 EDT 2008

On Aug 19, 2008, at 2:05 PM, Satish Gunnu wrote:

> Hi,
>   I am new to rspec and started implementing it on my project  
> yesterday.
> I have followed the instructions and installed rspec gem and rspec
> plugin into my project. I created couple of sample stories and tried
> running the specs using spec command which worked fine, but when I
> started using rake spec command it is loading development environment
> instead of test environment. I tried to putting some STDOUT's in
> spec_helper.rb but it seems that this file is never interpreted. Am I
> missing something? Please help, Thanks in advance.
> -SatishG
> -- 
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users

iirc, it looks at the development environment to prepare the db  
schema, but still runs the specs in test. Is that what you're seeing?

More information about the rspec-users mailing list