[rspec-users] rake spec loads development environment

Satish Gunnu lists at ruby-forum.com
Tue Aug 19 16:08:37 EDT 2008

Hi David,

  Most of my knowledge came from peepcode rspec screencast and the 
following link. 

Here are the steps I have done to get going.

 1) Installed rspec gem
 2) Installed rspec plugin in my project
 3) created a test_spec.rb file which have sample stories
 4) ruby script/generate rspec
 5) rake spec

  I have one initializer file for oracle_driver in initializers 
directory which is set to not load in test environment. when I run rake 
spec command this initializer is invoked and I see that the environment 
is set to development but not test.

To answer your second questions, I am not including it from my spec 

BTW I am using rpsec 1.1.4 and rails 2.1.0. Sorry for not being 
elaborate in my prev post.


David Chelimsky wrote:
> On Aug 19, 2008, at 1:05 PM, Satish Gunnu <lists at ruby-forum.com> wrote:
>> Hi,
>>  I am new to rspec and started implementing it on my project  
>> yesterday.
>> I have followed the instructions
> What instructions?
>> and installed rspec gem and rspec
>> plugin into my project. I created couple of sample stories and tried
>> running the specs using spec command which worked fine, but when I
>> started using rake spec command it is loading development environment
>> instead of test environment. I tried to putting some STDOUT's in
>> spec_helper.rb but it seems that this file is never interpreted.
> Are you including it from your spec files?

Posted via http://www.ruby-forum.com/.

More information about the rspec-users mailing list