[rspec-users] Autotest quits when code has errors

David Chelimsky dchelimsky at gmail.com
Mon Aug 4 21:45:09 EDT 2008


On Mon, Jul 28, 2008 at 5:10 PM, Evan Dorn <lists at ruby-forum.com> wrote:
> Sorry, I'd put this in a ZenTest forum (as opposed to RSpec), except
> that I can't find one.
>
> I find it frustrating that autotest keeps running when it finds failing
> tests - but it quits back to the command line whenever a test or code
> contains *errors*.

What do you mean "it quits back to the command line"?

> This means I have to constantly (like every 5 minutes) restart autotest
> by hand, which kind of defeats the purpose of autotest, and I find it
> hard to believe this is the default behavior.
>
> If I want to do TDD/BDD and call methods before they exist, this causes
> autotest to quit, which REALLY defeats the purpose.

That would suck, but I haven't had this experience.

> Am I doing something wrong, or is there a fix?   I'm using ZenTest 3.10
> with RSpec 1.1.5.

There has not been a 1.1.5 release, so I'm guessing you're using code
from github, right?

Can you provide a bit more about what you're doing? Are you using
Rails? If so, which version? If not, how are you organizing things?
Are you using a gem that you built?

Cheers,
David

>
> Thanks!
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list