[rspec-users] rspec 1.1.4

Juanma Cervera lists at ruby-forum.com
Wed Apr 16 03:45:38 EDT 2008


Hello.
I have some troubles with rails edge and decide to try rspec-1.1.4.

I have installed the plugins downloading the tarballs from github, and I
have this error message when I run autotest.

/home/jmcervera/work/chapado2/vendor/plugins/rspec_on_rails/lib/spec/rails/version.rb:11:
(RuntimeError)
############################################################################
Your RSpec on Rails plugin is incompatible with your installed RSpec.

RSpec          : 20080328014754
RSpec on Rails : 20080414041511

Make sure your RSpec on Rails plugin is compatible with your RSpec gem.
See http://rspec.rubyforge.org/documentation/rails/install.html for
details.
############################################################################
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:496:in
`require'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:342:in
`new_constants_in'
  from
/usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active_support/dependencies.rb:496:in
`require'
  from
/home/jmcervera/work/chapado2/vendor/plugins/rspec_on_rails/lib/spec/rails.rb:13
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
  from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
   ... 30 levels...
  from
/home/jmcervera/work/chapado2/vendor/plugins/rspec/lib/spec/runner/example_group_runner.rb:13:in
`load_files'
  from
/home/jmcervera/work/chapado2/vendor/plugins/rspec/lib/spec/runner/options.rb:86:in
`run_examples'
  from
/home/jmcervera/work/chapado2/vendor/plugins/rspec/lib/spec/runner/command_line.rb:19:in
`run'
  from script/spec:4


I have downloaded both tarballs from hithub today.
Which is the best way from installing the plugins from git.

Thanks

Juan M. Cervera
-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list