[rspec-users] Newbie : how to require to lib from spec under autotest?

Peter Fitzgibbons peter.fitzgibbons at gmail.com
Sat Apr 5 07:08:54 EDT 2008


On Sat, Apr 5, 2008 at 12:03 AM, Scott Taylor <mailing_lists at railsnewbie.com>
wrote:

>
> On Apr 5, 2008, at 12:38 AM, David Chelimsky wrote:
>
> On Apr 5, 2008, at 12:28 AM, "Peter Fitzgibbons" <
> peter.fitzgibbons at gmail.com> wrote:
>
> Hello all,
>
> I have the RSpec sample in ./rspec_bowling, with...
> ./rspec_bowling/lib/bowling.rb
> ./rspec_bowling/spec/spec.opts
> ./rspec_bowling/spec/bowling_spec.rb
>
> when I autotest, I get this:
> $autotest
> loading autotest/rspec
> /usr/local/bin/ruby -S
> /usr/local/lib/ruby/gems/1.8/gems/rspec-1.1.3/bin/spec -O spec/spec.opts
> spec/spec_helper.rb spec/bowling_spec.rb
> F
>
> 1)
> ArgumentError in 'Bowling should score 0 for gutter game'
> wrong number of arguments (1 for 0)
> [..snip..]
>
>
> This is the error - no path problem. There is a method expecting no
> arguments that is being called with one.
>
> HTH,
> David
>
>
> Sure - that test fails - but why do we see the next result? (see below)
>  What is rails doing in the background?
>
> Scott
>


This is not a rails app, it's standalone ruby.

And yes, as I highlighted,the interesting bit is the second run where
instead 'require' fails.

Thanks in advance for further discussion!

Peter
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rspec-users/attachments/20080405/8cfff371/attachment.html 


More information about the rspec-users mailing list