[rspec-users] How do you specify a rubygem is being required?

Ashley Moran work at ashleymoran.me.uk
Thu Oct 25 15:01:11 EDT 2007


On Oct 25, 2007, at 3:08 am, Al Chou wrote:

> I believe the current version uses the "gem" method and deprecates  
> the "require" method.  Rails warns me about something to that  
> effect whenever I run script/server, anyway.
>
> Not that I seem to have given you any real help with your spec  
> question....


Actually no, you were spot on!  Using gem allows me to write  
Kernel.gem / Kernel.should_receive(:gem) etc.

Thanks!
Ashley


-- 
blog @ http://aviewfromafar.net/
linked-in @ http://www.linkedin.com/in/ashleymoran
currently @ home



More information about the rspec-users mailing list