[rspec-users] Rspec Textmate bundle errors

Mel Riffe mriffe at gmail.com
Fri Oct 12 11:41:45 EDT 2007


Hey David,

This is what worked for me (just did this last night):

1. I removed everything rspec to have a clean slate:
  - gem uninstall rspec
  - rm -fr vendor/plugins/rpec
  - rm -fr vendor/plugins/rpec_on_rails
  - using BundleEditor, removed RSpec Bundle

2. I then installed the rspec plugins according to the website:
  - script/plugin install svn://..../tags/CURRENT/rspec
  - script/plugin install svn://..../tags/CURRENT/rspec_on_rails
  - script/generate spec
  - i then created a model rspec and ran 'rake spec'

3. I then installed the RSpec Bundle with the following SVN URL:
  - svn co .../tags/CURRENT/RSpec.tmbundle
  - Reloaded the Bundles
  - ran the same model spec from within TM.

You'll need to verify the instructions and get the correct svn URLs since
I'm doing this from memory.

HTH

Mel


On 10/12/07, David Currin <lists at ruby-forum.com> wrote:
>
> David Chelimsky wrote:
> > On 10/11/07, Brandon Keepers <bkeepers at gmail.com> wrote:
> >> >>> bundle.
> >> >> Opening a simple spec file and running the run behaviour
> description,
> >> >
> >> I can also confirm issues with the RSpec TextMate bundle as of this
> >>         from /opt/local/lib/ruby/gems/1.8/gems/builder-2.1.2/lib/
> >> 32:in `gem_original_require'
> >> workspaces_controller_spec.rb:1
> >> 27:in `gem_original_require'
> >> 27:in `require'
> >> latest revision.  I haven't investigated this, but I know edge rails
> >> is now bundling it's own version of Builder, in which it renamed the
> >> BlankSlate class to BasicObject.  Given the stack trace, I'm guessing
> >> that might have something to do with it.
> >
> > Also - I don't see 'RSpec' or 'rspec' anywhere in that stack trace.
> > It's all SharedSupport, rails and the app.
> >
> > Unfortunately, I'm not able to duplicate this. Anybody else having a
> > similar problem?
>
> I'm having the same problem:
>
> /Users/davidcurrin/Library/Application Support/TextMate/Pristine
> Copy/Bundles/RSpec.tmbundle/Support/lib/spec_mate.rb:2:in `require': No
> such file to load -- rubygems (LoadError) from
> /Users/davidcurrin/Library/Application Support/TextMate/Pristine
> Copy/Bundles/RSpec.tmbundle/Support/lib/spec_mate.rb:2 from
> /tmp/temp_textmate.OqOjcI:3:in `require' from
> /tmp/temp_textmate.OqOjcI:3
>
>
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rspec-users/attachments/20071012/eec262dd/attachment.html 


More information about the rspec-users mailing list