[rspec-users] Rspec Textmate bundle errors

David Currin lists at ruby-forum.com
Fri Oct 12 11:26:45 EDT 2007

David Chelimsky wrote:
> On 10/11/07, Brandon Keepers <bkeepers at gmail.com> wrote:
>> >>> bundle.
>> >> Opening a simple spec file and running the run behaviour description,
>> >
>> I can also confirm issues with the RSpec TextMate bundle as of this
>>         from /opt/local/lib/ruby/gems/1.8/gems/builder-2.1.2/lib/
>> 32:in `gem_original_require'
>> workspaces_controller_spec.rb:1
>> 27:in `gem_original_require'
>> 27:in `require'
>> latest revision.  I haven't investigated this, but I know edge rails
>> is now bundling it's own version of Builder, in which it renamed the
>> BlankSlate class to BasicObject.  Given the stack trace, I'm guessing
>> that might have something to do with it.
> Also - I don't see 'RSpec' or 'rspec' anywhere in that stack trace.
> It's all SharedSupport, rails and the app.
> Unfortunately, I'm not able to duplicate this. Anybody else having a
> similar problem?

I'm having the same problem:

/Users/davidcurrin/Library/Application Support/TextMate/Pristine 
Copy/Bundles/RSpec.tmbundle/Support/lib/spec_mate.rb:2:in `require': No 
such file to load -- rubygems (LoadError) from 
/Users/davidcurrin/Library/Application Support/TextMate/Pristine 
Copy/Bundles/RSpec.tmbundle/Support/lib/spec_mate.rb:2 from 
/tmp/temp_textmate.OqOjcI:3:in `require' from 

Posted via http://www.ruby-forum.com/.

More information about the rspec-users mailing list