[rspec-users] TextMate language weirdness

Carl Porth badcarl at gmail.com
Thu Oct 4 18:26:23 EDT 2007


Thanks for the tip, I'll report back if I find a solution.

Carl

On Oct 3, 2007, at 4:08 PM, Wincent Colaiuta wrote:

> El 3/10/2007, a las 22:23, Carl Porth escribió:
>
>> I'm having trouble with TextMate and assigning the RSpec language to
>> *_spec.rb files within rails projects.  Here is what is happening:
>>
>> I'm in a file that has the language "Ruby on Rails" selected.
>> I do a ctrl-shift-down to switch to the corresponding _spec.rb file.
>> The _spec.rb file has the language "Ruby on Rails" selected.
>> I change the language to "RSpec".
>> I then do a ctrl-shift-down to switch back to the rails file.
>> The rails file has the language "Ruby" selected.
>> I select the language "Ruby on Rails" and the whole vicious cycle
>> begins again.
>>
>> (No files remember what language they are supposed to be.)
>>
>> I'm running TextMate build 1414 and RSpec.tmbundle r2691.
>>
>> Anyone else experiencing the same behavior?
>>
>> Is the problem with me, TextMate or RSpec.tmbundle or something
>> completely different?
>
> I was experiencing similar problems and opened a couple of tickets
> for them:
>
> <http://macromates.com/ticket/show?ticket_id=48BF3775>
> <http://macromates.com/ticket/show?ticket_id=0F597093>
>
> If you think your issue is related then it might be worth adding a
> comment there. I never got to the bottom of it and the issues were
> closed.
>
> Cheers,
> Wincent
>
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users



More information about the rspec-users mailing list