[rspec-users] Broken edge

Daniel Tenner daniel.ruby at tenner.org
Wed Nov 28 11:39:49 EST 2007


Ok, I've ditched externals and switched to piston... wiped out all  
the plugins and reinstalled them...

And still I'm getting that error.

No one else is getting this?

Daniel

On 28 Nov 2007, at 14:49 28 Nov 2007, David Chelimsky wrote:

> On Nov 28, 2007 8:44 AM, Daniel Tenner <daniel.ruby at tenner.org> wrote:
>> 8228 and 2997! :-(
>>
>> Dang.. what else could it be? It looks like basically, "render" is
>> what's broken... all the pages with redirect_to are working fine in
>> the specs. When I take one of the broken actions and make it
>> redirect_to instead of rendering, the number of failures goes down,
>> and the line that's breaking in controller_example_group.rb is:
>>                  super(options, deprecated_status, &block)
>>
>> in the render method of the ControllerInstanceMethods module.
>>
>> No idea why it breaks though (or why it's breaking only for me!)...
>
> Did you do a clean install of edge rails, rspec and rspec_on_rails? If
> not, I'd recommend it. Perhaps it's an update problem (as Stefan
> proposed) as opposed to a code problem.
>
>>
>> Daniel
>>
>>
>> On 28 Nov 2007, at 14:36 28 Nov 2007, David Chelimsky wrote:
>>
>>> On Nov 28, 2007 8:29 AM, Daniel Tenner <daniel.ruby at tenner.org>  
>>> wrote:
>>>> Hi all,
>>>>
>>>> Not sure if I'm the only one with this problem...
>>>>
>>>> We're on edge for both rails and rspec, and i just did an update...
>>>> Some apparently innocuous rails stuff was updated, and then half my
>>>> specs broke due to an error in rspec_on_rails:
>>>> ArgumentError in 'UserController without logged in user should show
>>>> the index page'
>>>> wrong number of arguments (2 for 1)
>>>> ..../vendor/plugins/rspec_on_rails/lib/spec/rails/example/ 
>>>> behaviour/
>>>> controller_example_group.rb:188:in `render'
>>>>
>>>> I tried backtracking to an earlier version of rails with no luck.
>>>>
>>>> Can anyone provide some version numbers (for rspec, rspec on rails,
>>>> and rails itself) that I can downgrade back to so my specs work
>>>> again?
>>>
>>> I just updated to edge rails 8228 and it runs fine with rspec at rev
>>> 2997 (current trunk)
>>>
>>> What revisions are you using?
>>>
>>>>
>>>> Thanks a lot!
>>>>
>>>> Daniel
>>>> _______________________________________________
>>>> rspec-users mailing list
>>>> rspec-users at rubyforge.org
>>>> http://rubyforge.org/mailman/listinfo/rspec-users
>>>>
>>> _______________________________________________
>>> rspec-users mailing list
>>> rspec-users at rubyforge.org
>>> http://rubyforge.org/mailman/listinfo/rspec-users
>>
>> _______________________________________________
>> rspec-users mailing list
>> rspec-users at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/rspec-users
>>
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users



More information about the rspec-users mailing list