[rspec-users] Textmate Bundle Errors

Andrew Edwards lists at ruby-forum.com
Fri Nov 23 11:54:31 EST 2007


Running #rake spec seems to work as expected, however using cmd+r in
textmate does not. I assume Textmate has some specific references to
rails or ruby which I have not set.

I have set the TM_RUBY to /usr/local/bin/ruby as suggested in the RSpec

I am running OS X 10.5 with a manually compiled ruby 1.8.6 (2007-03-13
patchlevel 0) [i686-darwin8.10.1] and gem 0.9.4. This was installed
prior to upgrading to 10.5 which I hear includes its own version of ruby
and gems.

I am using rspec and rspec_on_rails rev 2962 (trunk) and have installed
RSpec.tmbundle from the same revision. I am using using the trunk
version as my project is using Rails RC1 (installed as the system
version of Rails as opposed to frozen to the project, reported as
version 1.99.0).

When viewing a _spec.rb file and using cmd+r I get the following error:

Cannot find gem for Rails ~>1.99.0: Install the missing gem with 'gem
install -v=1.99 rails', or change environment.rb to define
RAILS_GEM_VERSION with your desired version.

Thanks for any pointers,

Posted via http://www.ruby-forum.com/.

More information about the rspec-users mailing list