[rspec-users] Initial run of RSpec 1.0.8 on MS-WinXPproSP2

James B. Byrne byrnejb at harte-lyne.ca
Thu Nov 22 17:06:46 EST 2007


On Thu, November 22, 2007 16:31, David Chelimsky wrote:

>
> RSpec 1.0.8 supports rails 1.2.3 or earlier. If you want to work w/
> anything later than Rails 1.2.3 you'll need rspec's trunk.
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>

I deleted the rpsec gem and the rspec and rpec_on_rails plugins. I then
installed rspec from the trunk (svn://rubyforge.org/var/svn/rspec/trunk)
via Tortoise SVN.  I deleted the ./spec directory tree from the app root
and ran ruby script/generate rspec_model product.  When I run rake
spec:models I get the same error.

Regards,


P.S.

rake doc:plugins produces no output for the trunk version of rspec.  Is
this  expected behaviour or does it indicate a problem?

C:\Documents and Settings\byrnejb\My Documents\My
Projects\ca.harte-lyne.system\pragdepot>rake doc:plugins
(in C:/Documents and Settings/byrnejb/My Documents/
       My Projects/ca.harte-lyne.system/pragdepot)
rdoc.bat -o doc/plugins/rspec --title 'Rspec Plugin Documentation'
--line-numbers --inline-source -T html --main 'vendor/plugins/rspec/
README' vendor/plugins/rspec/README

                             README:
Generating HTML...

Files:   1
Classes: 0
Modules: 0
Methods: 0
Elapsed: 0.313s

??

-- 
***          E-Mail is NOT a SECURE channel          ***
James B. Byrne                mailto:ByrneJB at Harte-Lyne.ca
Harte & Lyne Limited          http://www.harte-lyne.ca
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3



More information about the rspec-users mailing list