[rspec-users] Autotest rspec issues

Brad Carson lists at ruby-forum.com
Tue Nov 20 12:23:33 EST 2007


I'm having trouble getting autotest to run "out of the box" with rspec.
I've got a Leopard setup with Zentest 3.5.0, rspec on trunk, and rails
2.0PR.  No ".autotest" file.

There are a couple of issues:
1. Running 'autotest' inititally yields a command not found for "spec
--diff unified etc etc".   This seems to be an old issue but I can fix
it by creating a "~/.autotest" file and attaching a hook to autotest
initialize to explicity set the spec_command to script/spec.  Fine.

2. Regardless of #1, restarting autotest once loaded makes it crap out
with an initialize error, complaining about wrong arguments (0 for 1) or
somesuch - the exact stack trace and error I can post when home again
tonight.

3. I can live with the first two, but autotest isn't picking up any
changes to any view specs.  I've tried index.rhtml_spec.rb and
index.html.erb_spec.rb but nothing does the trick.  Controller spec
changes are detected just fine.  Haven't tried model specs yet.

I'd love to hear any suggestions you may have and thank you kindly in
advance.

Brad
-- 
Posted via http://www.ruby-forum.com/.


More information about the rspec-users mailing list