[rspec-users] helper methods starting with should
glenn at aldenta.com
Mon Nov 19 00:13:44 EST 2007
I, as a new rspec user, did not find the switch between test_ and it
"blah" do to be even a small challenge compared to other things I had
to convert and learn. I only feel like it would be one more thing to
keep up with that would cause problems. I can certainly see someone
writing a helper method with should_ and saying "what the heck is
going on" because they didn't fully read all the documentation. It
was plenty easy in my conversion to say "oh ok, find and replace test_
and put it "should" in place of that". I would have certainly been
frustrated to find a hidden "feature" causing problems that I didn't
Keeping in mind my original n00b perspective, I feel like if in my
first impression I had the option of turning on a baby-step feature
that I might have either, A - not known about it because I didn't see
it in my first tutorial, or, B - skipped it feeling that I could
handle making that transition into the "accepted" way.
I can see how some people might find use for it, but I believe overall
the complexity would cause more confusion than it would prevent.
There's my 2 cents.
On Nov 18, 2007, at 1:52 PM, Shane Mingins wrote:
> On 19/11/2007, at 5:05 AM, Nathan Sutton wrote:
>> Keep it, but make it a configuration option with default-off.
>> Nathan Sutton
>> fowlduck at gmail.com
>> rspec edge revision 2894
>> rspec_on_rails edge revision 2894
>> rails edge revision 8146
> I agree. +1 configuration with default being current behaviour.
> rspec-users mailing list
> rspec-users at rubyforge.org
More information about the rspec-users