[rspec-users] error on migration

Patrick Aljord patcito at gmail.com
Thu Nov 8 10:22:55 EST 2007


Hi all,

I'm just getting started with rspec. I'm using trunk rspec with edge
rails. I get an error on migration though, here it is:

rake db:migrate RAILS_ENV="test" --trace
(in /home/pat/railsapp)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
rake aborted!
undefined method `failure_message' for class `Spec::Matchers::Have'
/home/pat/railsapp/vendor/plugins/rspec_on_rails/lib/spec/matchers/have.rb:4:in
`alias_method'
/home/pat/railsapp/vendor/plugins/rspec_on_rails/lib/spec/matchers/have.rb:4
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
/home/pat/railsapp/vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:496:in
`require'
/home/pat/railsapp/vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:342:in
`new_constants_in'
/home/pat/railsapp/vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:496:in
`require'
/home/pat/railsapp/vendor/plugins/rspec_on_rails/lib/spec/matchers.rb:3
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
/home/pat/railsapp/vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:496:in
`require'
/home/pat/railsapp/vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:342:in
`new_constants_in'
/home/pat/railsapp/vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:496:in
`require'
/home/pat/railsapp/vendor/plugins/rspec/lib/spec.rb:3
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
/home/pat/railsapp/vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:496:in
`require'
/home/pat/railsapp/vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:342:in
`new_constants_in'
/home/pat/railsapp/vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:496:in
`require'
/home/pat/railsapp/vendor/plugins/rspec/init.rb:2:in `evaluate_init_rb'
/home/pat/railsapp/config/../vendor/rails/railties/lib/rails/plugin.rb:78:in
`evaluate_init_rb'
/home/pat/railsapp/vendor/rails/activerecord/lib/../../activesupport/lib/active_support/core_ext/kernel/reporting.rb:11:in
`silence_warnings'
/home/pat/railsapp/config/../vendor/rails/railties/lib/rails/plugin.rb:74:in
`evaluate_init_rb'
/home/pat/railsapp/config/../vendor/rails/railties/lib/rails/plugin.rb:38:in
`load'
/home/pat/railsapp/config/../vendor/rails/railties/lib/rails/plugin/loader.rb:33:in
`load_plugins'
/home/pat/railsapp/config/../vendor/rails/railties/lib/rails/plugin/loader.rb:32:in
`each'
/home/pat/railsapp/config/../vendor/rails/railties/lib/rails/plugin/loader.rb:32:in
`load_plugins'
/home/pat/railsapp/config/../vendor/rails/railties/lib/initializer.rb:189:in
`load_plugins'
/home/pat/railsapp/config/../vendor/rails/railties/lib/initializer.rb:105:in
`process'
/home/pat/railsapp/config/../vendor/rails/railties/lib/initializer.rb:49:in
`send'
/home/pat/railsapp/config/../vendor/rails/railties/lib/initializer.rb:49:in
`run'
/home/pat/railsapp/config/environment.rb:13
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
/home/pat/railsapp/vendor/rails/railties/lib/tasks/misc.rake:3
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in `call'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:362:in `invoke'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in `synchronize'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in `invoke'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:369:in `invoke_prerequisites'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1003:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1003:in `send'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1003:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:368:in `invoke_prerequisites'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:361:in `invoke'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in `synchronize'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in `invoke'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in
`standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1733:in `top_level'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1711:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in
`standard_exception_handling'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1708:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.3/bin/rake:7
/usr/bin/rake:16:in `load'
/usr/bin/rake:16

any idea how to fix this?

thanks in advance

Pat


More information about the rspec-users mailing list