[rspec-users] rspec on rails update question

aslak hellesoy aslak.hellesoy at gmail.com
Fri May 25 11:35:11 EDT 2007

On 5/25/07, Jonathan Linowes <jonathan at parkerhill.com> wrote:
> I'm sure this is OT but I'd appreciate the help
> I'm using rspec_on_rails
> I prefer to use stable release rather than live dangerously (at least
> until I can tell the difference between what I might be doing wrong
> vs problems in rspec). However, I would like to try the
> RspecScaffoldGenerator fix.
> I installed (per the docs) last week with the following commands
>    $ ruby script/plugin install -x svn://rubyforge.org/var/svn/rspec/
> tags/REL_1_0_0/rspec
>    $ ruby script/plugin install -x svn://rubyforge.org/var/svn/rspec/
> tags/REL_1_0_0/rspec_on_rails
>    $ script/generate rspec
> Should I have said REL_1_0_2 instead? Will svn up find the latest tags?

REL_* tags will never move. However, you can get the CURRENT tag (new
as of today), which will always give you the latest release. Sort of
like trunk, but you won't get the unstable bits between each release.

> When I run
>    $ svn up vendor/plugins/rspec
> At revision 2032.
>    $ svn up vendor/plugins/rspec_on_rails
> At revision 2032.
> How can i tell which version is actually installed on my system now?

After you do an svn up, you must rebootstrap rspec:

  script/generate rspec


  ruby script/spec -v

..will tell you the current RSpec version - as well as the svn revision.

> perhaps I don't know svn well enough to identify the tags

stand in the plugin and do svn info. you should get the same revision
info as script/spec -v

> I would like 1.0.3, its listed under http://rspec.rubyforge.org/
> changes.html but tags/REL_1_0_3 doesn't seem to exist yet, right?

1.0.3 is not released yet. The changes file has info on what's coming
because we sometimes upload the web site between releases.

> It
> tried
>    $ ruby script/plugin install -x --force svn://rubyforge.org/var/
> svn/rspec/tags/REL_1_0_3/rspec
> svn: URL 'svn://rubyforge.org/var/svn/rspec/tags/REL_1_0_3/rspec'
> doesn't exist
> Is that the way to upgrade?

I think so.


> thanks
> linoj
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users

More information about the rspec-users mailing list