[rspec-users] 0.9.2 redirect_to no longer accepts hash?

David Chelimsky dchelimsky at gmail.com
Thu May 3 15:11:56 EDT 2007


On 5/3/07, Chris Hoffman <chris.c.hoffman at gmail.com> wrote:
> Hi David,
>   I'm sorry, I didn't set up my specs correctly again.  It has just
> been difficult sorting through what was caused by the translator (I'm
> still migrating to 0.9.x) versus what I'm actually doing wrong.  Sorry
> for my confused rant.

No worries. The translator isn't perfect (that would have cost too
much!) - so keep letting us know if we can help.

Cheers,
David

>
> -Chris
>
> On 5/3/07, David Chelimsky <dchelimsky at gmail.com> wrote:
> > What is the spec that is failing?
> >
> > On 5/3/07, Chris Hoffman <chris.c.hoffman at gmail.com> wrote:
> > > Why am I now getting these errors?
> > >
> > > expected redirect to {:action=>"index"}, got redirect to
> > > "http://test.host/authenticated_users"
> > >
> > > I know in the AuthenticatedUsersController, the redirect call is
> > >
> > > redirect_to :action => 'index'
> > >
> > > So why should I have to convert this to a url in my specs?
> > > _______________________________________________
> > > rspec-users mailing list
> > > rspec-users at rubyforge.org
> > > http://rubyforge.org/mailman/listinfo/rspec-users
> > >
> > _______________________________________________
> > rspec-users mailing list
> > rspec-users at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/rspec-users
> >
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list