[rspec-users] sqlite3 and rspec_on_rails tests

M. Edward (Ed) Borasky znmeb at cesmail.net
Tue Mar 27 10:04:05 EDT 2007


aslak hellesoy wrote:
> On 3/27/07, Scott Taylor <mailing_lists at railsnewbie.com> wrote:
>   
>> As I think I previously mentioned, there is an incompatibility with
>> rails 1.2.1 and sqlite3 3.3.8.
>>
>> see: http://weblog.rubyonrails.org/2007/1/29/using-sqlite3-with-rails
>> and: http://weblog.rubyonrails.org/2007/2/6/rails-1-2-2-sqlite3-gems-
>> singular-resources
>>
>> Sqlite is now at 3.3.13.
>>
>> Because of this, if a developer is trying to create a patch for
>> rspec_on_rails, he will have one of the following two problems (if he
>> is using sqlite):
>>
>> 1. the rails 1.2.1 specs will fail, if sqlite > 3.3.7
>> 2. the rails 1.2.2 and greater will fail if sqlite is < 3.3.8.
>>
>> This renders running all of the specs as impossible with sqlite,
>> doesn't it?
>>
>>     
>
> Maybe it's time to retire RSpec's support for Rails pre 1.2.2?
>
> WDYT?
>   
Well, in the case of commercial projects, there's usually strong 
pressure from the vendor to minimize vendor support costs by only 
supporting the latest general release version and only one older one. 
However, since their stuff costs money, a lot of customers will attempt 
to keep more ancient technology alive as long as possible.

But in a "free" world, there hardly seems to be any reason to support 
versions older than general release. Maybe you'd want to support general 
release minus one. So my vote is to do what makes life easier for RSpec, 
and if that means support only 1.2.2, do it. Then again, I run testing 
systems anyhow -- I don't think I have much "general release" level code 
on my boxes. :)

-- 
M. Edward (Ed) Borasky, FBG, AB, PTA, PGS, MS, MNLP, NST, ACMC(P)
http://borasky-research.blogspot.com/

If God had meant for carrots to be eaten cooked, He would have given rabbits fire.



More information about the rspec-users mailing list