[rspec-users] RC1, Rails, and problems with multiple options in spec.opts

Coda Hale coda.hale at gmail.com
Wed Mar 7 13:47:33 EST 2007


You need to have a single option per line.

E.g.:

--drb
--color
--diff

On 3/7/07, johnnybutler7 <JohnnyButler7 at gmail.com> wrote:
>
> I too have this problem.  What is the format for adding options to spec.opts
> file, i cant seem to find anything on the web.  Are spaces include so for
> instance are any of the below valid?:
>
> --drb --colour
> --drb--colour
> --drb colour
> --drb -colour
>
>
> JB
>
> Scott Taylor-6 wrote:
> >
> > I am having inconsistent output with multiple options in the
> > spec.opts file.  I can, for instance, pass --color or --colour, or,
> > separately, use --drb.  But when combining them I get:
> >
> > /opt/local/lib/ruby/1.8/optparse.rb:1381:in `complete': invalid
> > option: --options --color --drb (OptionParser::InvalidOption)
> >          from /opt/local/lib/ruby/1.8/optparse.rb:1379:in `catch'
> >          from /opt/local/lib/ruby/1.8/optparse.rb:1379:in `complete'
> >          from /opt/local/lib/ruby/1.8/optparse.rb:1212:in `order!'
> >          from /opt/local/lib/ruby/1.8/optparse.rb:1205:in `catch'
> >          from /opt/local/lib/ruby/1.8/optparse.rb:1205:in `order!'
> >          from /opt/local/lib/ruby/1.8/optparse.rb:1279:in `permute!'
> >          from /opt/local/lib/ruby/1.8/optparse.rb:1300:in `parse!'
> >          from /Users/smtlaissezfaire/Sites/rails/dictionary/vendor/
> > plugins/rspec/lib/spec/runner/option_parser.rb:180:in `parse'
> >           ... 9 levels...
> >          from /Users/smtlaissezfaire/Sites/rails/dictionary/vendor/
> > plugins/rspec/lib/spec/runner/option_parser.rb:180:in `parse'
> >          from /Users/smtlaissezfaire/Sites/rails/dictionary/vendor/
> > plugins/rspec/lib/spec/runner/option_parser.rb:13:in
> > `create_context_runner'
> >          from /Users/smtlaissezfaire/Sites/rails/dictionary/vendor/
> > plugins/rspec/lib/spec/runner/command_line.rb:12:in `run'
> >          from /Users/smtlaissezfaire/Sites/rails/dictionary/vendor/
> > plugins/rspec/bin/spec:4
> > rake aborted!
> >
> > Is anyone else having this problem?
> >
> > I'm on Mac OS X.4.8, using edge rails, ruby 1.8.5, and RC1
> >
> > Best,
> >
> > Scott Taylor
> > _______________________________________________
> > rspec-users mailing list
> > rspec-users at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/rspec-users
> >
> >
>
> --
> View this message in context: http://www.nabble.com/RC1%2C-Rails%2C-and-problems-with-multiple-options-in-spec.opts-tf3330529.html#a9358217
> Sent from the rspec-users mailing list archive at Nabble.com.
>
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


-- 
Coda Hale
http://blog.codahale.com


More information about the rspec-users mailing list