[rspec-users] Windows rspec "gem install win32console"

johnnybutler7 JohnnyButler7 at gmail.com
Tue Mar 6 05:13:10 EST 2007


I have removed the --colour from the spec.opts file to see if it was just a
colour problem.

I now get this error below, i am using rails 1.2.2:

** Execute spec:models
C:/ruby/bin/ruby -I"C:/ruby/lib/ruby/gems/1.8/gems/rspec-0.8.2/lib"
"C:/ruby/lib/ruby/gems/1.8/gems/rspec-0.8.2/bin/spec"
"spec/models/user_spec.rb" --options "C:/Documents and
Settings/JohnButler/My Documents/Ruby on
Rails/eclipse/workspace/Workspace/sports/config/../spec/spec.opts" 
C:/ruby/lib/ruby/gems/1.8/gems/rspec-0.8.2/lib/spec/runner/command_line.rb:26:in
`run': File or directory not found:  (RuntimeError)
	from
C:/ruby/lib/ruby/gems/1.8/gems/rspec-0.8.2/lib/spec/runner/command_line.rb:18:in
`each'
	from
C:/ruby/lib/ruby/gems/1.8/gems/rspec-0.8.2/lib/spec/runner/command_line.rb:18:in
`run'
	from
C:/ruby/lib/ruby/gems/1.8/gems/rspec-0.8.2/lib/spec/runner/option_parser.rb:149:in
`parse'
	from C:/ruby/lib/ruby/1.8/optparse.rb:1218:in `call'
	from C:/ruby/lib/ruby/1.8/optparse.rb:1218:in `order!'
	from C:/ruby/lib/ruby/1.8/optparse.rb:1205:in `catch'
	from C:/ruby/lib/ruby/1.8/optparse.rb:1205:in `order!'
	from C:/ruby/lib/ruby/1.8/optparse.rb:1279:in `permute!'
	from C:/ruby/lib/ruby/1.8/optparse.rb:1300:in `parse!'
	from
C:/ruby/lib/ruby/gems/1.8/gems/rspec-0.8.2/lib/spec/runner/option_parser.rb:185:in
`parse'
	from
C:/ruby/lib/ruby/gems/1.8/gems/rspec-0.8.2/lib/spec/runner/option_parser.rb:18:in
`create_context_runner'
	from
C:/ruby/lib/ruby/gems/1.8/gems/rspec-0.8.2/lib/spec/runner/command_line.rb:14:in
`run'
	from C:/ruby/lib/ruby/gems/1.8/gems/rspec-0.8.2/bin/spec:4
** Invoke spec:controllers (first_time)
** Invoke db:test:prepare 
** Execute spec:controllers
** Invoke spec:helpers (first_time)
** Invoke db:test:prepare 
** Execute spec:helpers
** Invoke spec:views (first_time)
** Invoke db:test:prepare 
** Execute spec:views
rake aborted!
RSpec failures
C:/Documents and Settings/JohnButler/My Documents/Ruby on
Rails/eclipse/workspace/Workspace/sports/config/../vendor/plugins/rspec_on_rails/tasks/rspec.rake:32
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in `call'
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in `execute'
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in `each'
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in `execute'
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:357:in `invoke'
C:/ruby/lib/ruby/1.8/thread.rb:135:in `synchronize'
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:in `invoke'
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in `run'
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in `each'
C:/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in `run'
C:\ruby\lib\ruby\gems\1.8\gems\rake-0.7.1\bin\rake:7
-e:3:in `load'
-e:3

I really want to use RSpec with my rails development but cant it running
properly.

JB





johnnybutler7 wrote:
> 
> Hi,
> 
> Hi I am trying to use RSPEC on windows and i keep getting the following
> error
> 
> "You must gem install win32console to use colour on Windows"
> 
> I have installed this Gem but i am still getting the same error.  The
> file that error is coming from is:
> C:\ruby\lib\ruby\gems\1.8\gems\rspec-0.8.2\lib\spec\runner\formatter\base_text_formatter.rb
> 
> Do i need to put this line of code in?  Where do i put it?
> require 'Win32/Console/ANSI'
> 
> Can anyone help me, ive searched the web but cant seem to find a
> solution.
> 
> JB
> 

-- 
View this message in context: http://www.nabble.com/Windows-rspec-%22gem-install-win32console%22-tf3354239.html#a9328875
Sent from the rspec-users mailing list archive at Nabble.com.



More information about the rspec-users mailing list