[rspec-users] [ANN] RSpec-0.8.2

David Chelimsky dchelimsky at gmail.com
Fri Mar 2 11:26:26 EST 2007

Announcing the release of rspec-0.8.2.

This should only affect a small number of you, but I re-wrote the
assert_select fork as a wrapper. The only effect this has on the API
is that :hide and :effect are not supported by "should have_rjs", as
they are not supported by assert_select_rjs.

You can, however, still use them both with "should_have_rjs" (with an
underscore between "should" and "have").

The reason for this change is that only a day after releasing 0.8, I
discovered that the specs for should have_rjs were failing against
edge rails. I quickly realized that it makes no sense for us to
maintain forks of anything in rails. I guess I knew that already, but
simply ignored my better judgment when writing the fork because I
wanted better messages (the failure messages in assert_select are not
that helpful).

Thanks for your patience w/ this.

The RSpec Development Team

More information about the rspec-users mailing list