[rspec-users] installing trunk (was: upgrading from CURRENT to trunk)

Jonathan Linowes jonathan at parkerhill.com
Tue Jul 31 22:48:11 EDT 2007


Hi, I must be missing something obvious.

	$ rm -rf vendor/plugins/rspec

	$ script/plugin install svn://rubyforge.org/var/svn/rspec/trunk rspec
Exported revision 2188.
Plugin not found: ["svn://rubyforge.org/var/svn/rspec/trunk", "rspec"]

	$ ls vendor/plugins
rspec/                  (etc)

	$ ls vendor/plugins/rspec
README                  Rakefile                 
example_rails_app/      rspec/                  spec_distributed/
RSpec.tmbundle/         doc/                     
pre_commit/             rspec_on_rails/         spec_ui/


but if i manually shuffle things around, then i'm ok:

	$ mv vendor/plugins/rspec ~/
	$ mv ~/rspec/rspec vendor/plugins/
	$ mv ~/rspec/rspec_on_rails vendor/plugins/

this works

Probably a script or svn thing I'm doing wrong?


More information about the rspec-users mailing list