[rspec-users] upgrading from CURRENT to trunk

Jonathan Linowes jonathan at parkerhill.com
Tue Jul 31 15:11:09 EDT 2007

I've been on CURRENT
I tried to switch to trunk but its not completing.
How do I install the trunk version? (for rails)

(I apologize in advance for being clueless)

Here's my steps:

First, I brought everything I have up to date:
	$ sudo gem update ZenTest
	$ sudo gem update rspec
	$ script/plugin update rspec
	$ script/plugin update rspec_on_rails

and realized I'm on CURRENT, so I then did:

	$ rm -rf vendor/plugins/rspec
	$ rm -rf vendor/plugins/rspec_on_rails
	$ script/plugin install svn://rubyforge.org/var/svn/rspec/trunk  
Plugin not found: ["svn://rubyforge.org/var/svn/rspec/trunk",  

Unsure about that error, I then tried to build it

	$ cd vendor/plugins/rspec
	$ rake

kept getting errors about missing gems, installed the gems and rake'd  
again until it told me to run:

	$ rake install_dependencies

which does a bunch of stuff and then actually installs rails/1.2.2  
under vendor/plugins/rspec/example_rails_app/vendor/rails/1.2.2/
and then also installs 1.2.3 ... and then also edge... UGH!!
I stopped it before it finished, as i really dont want/need the  
sample app and rails versions

More information about the rspec-users mailing list