[rspec-users] need help getting a word right

Robert Feldt robert.feldt at bth.se
Wed Jul 18 23:44:05 EDT 2007


On 7/19/07, David Chelimsky <dchelimsky at gmail.com> wrote:
>
> Hey all,
>
> I see examples showing up that look like this:
>
> describe Thing do
>   before(:each) do
>     @thing = Thing.new
>   end
>
>   it do
>     @thing.should be_something
>   end
> end
>
> This will produce output like this:
>
> Thing
> - should be something
>
> But "it do" is driving me mad :(
>
> We need a better word. Of course, 'specify' has not been completely
> removed, so you can still do this:
>
> describe Thing do
>   before(:each) { @thing = Thing.new }
>   specify { @thing.should be_something }
> end
>
> Consise? Yes. But I'm not psyched about 'specify' either. There IS a
> perfect word for this situation. What is it? Suggestions?


I like "should" or "spec" the best.

While I'm at it why not "given" instead of "describe"?

Cheers,

Robert Feldt
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rspec-users/attachments/20070719/b3a44391/attachment.html 


More information about the rspec-users mailing list