[rspec-users] spec not running in TextMate

Brian Yamabe brian at yamabe.net
Wed Jan 10 07:21:12 EST 2007


I do have TM_RUBY set to the same Ruby interpreter as the one I use  
from the terminal.

---Brian

On Jan 10, 2007, at 1:49 AM, aslak hellesoy wrote:

> Sounds like TM is running a Ruby interpreter that doesn't have
> Rubygems installed.
>
> Tell TM to run a different Ruby - it's documented somewhere, but I
> don't remember where.
>
> Aslak
>
> On 1/10/07, Bryan Helmkamp <bhelmkamp at gmail.com> wrote:
>> I don't have any help to offer, but I can confirm that I'm
>> experiencing this issue right now, as well as some other people I  
>> have
>> spoken with.
>>
>> -Bryan
>>
>> On 1/9/07, Brian Yamabe <brian at yamabe.net> wrote:
>>> I tried running a spec with command-r in TextMate and got:
>>>
>>> /Library/Application Support/TextMate/Bundles/RSpec.tmbundle/ 
>>> Support/
>>> lib/spec_mate.rb:1:in `require': No such file to load -- rubygems
>>> (LoadError) from /Library/Application Support/TextMate/Bundles/
>>> RSpec.tmbundle/Support/lib/spec_mate.rb:1 from /tmp/
>>> temp_textmate.GplhPr:3:in `require' from /tmp/temp_textmate.GplhPr:3
>>>
>>> The spec runs fine from the command line.
>>>
>>> Any ideas?
>>>
>>> Thanks,
>>> Brian
>>> _______________________________________________
>>> rspec-users mailing list
>>> rspec-users at rubyforge.org
>>> http://rubyforge.org/mailman/listinfo/rspec-users
>>>
>> _______________________________________________
>> rspec-users mailing list
>> rspec-users at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/rspec-users
>>
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users



More information about the rspec-users mailing list