[rspec-users] spec.opts

Wayne Larsen wayne at larsen.st
Tue Feb 13 16:40:12 EST 2007

On 13-Feb-07, at 4:01 PM, aslak hellesoy wrote:

> On 2/13/07, James Hughes <hughes.james at gmail.com> wrote:
>> Hi,
>> Just built the gem from trunk for the first time and ran into an  
>> issue
>> with the generated spec.opts file (rev. 1493). Moving the file out of
>> the way fixed the problem. I'm not on windows, so this is not a
>> win32console gem issue as per the README.
> You have to tell us the steps to reproduce this.
> It's odd that the spec.opts file is part of the backtrace.

spec.opts seems to be very picky about extra whitespace.  I ran into  
a very similar stack trace (I had to first test --color in place of -- 
colour to se if that was the problem.. :).  After I removed extra  
whitespace from the end of the file it worked.

I also ran into a problem when there is no spec.opts file:

option_parser.rb:143:in `readlines': No such file or directory - / 
         from /opt/local/lib/ruby/gems/1.8/gems/rspec-0.8.0/lib/spec/ 
runner/option_parser.rb:143:in `parse'

It would be nice if there is a test for the file, and it is only used  
if it exists.



More information about the rspec-users mailing list