[rspec-users] Do you think it would look cleaner?

Kero van Gelder kero at chello.nl
Sun Dec 30 04:47:26 EST 2007


> I was looking over some of my specs.
> I was thinking that the following:
> 
> @game.should_receive(:name).and_return('The Battle for Blaze')
> @game.should_receive(:people).and_return(5000000)
> @game.should_receive(:activated).and_return(true)
> 
> Would it look cleaner if I could do this instead?
> 
> @game.should_recieve_and_return(
>   :name => 'The Battle for Blaze'
>   :people => 5000000
>   :activated => true)
> 
> Opinions?

A Hash is not ordered.
(but the 1st set of statements is)

Bye,
Kero.


More information about the rspec-users mailing list