[rspec-users] Do you think it would look cleaner?
dchelimsky at gmail.com
Sun Dec 30 07:04:39 EST 2007
On Dec 30, 2007 6:52 AM, Jean-François Trân <jftran at rubyfrance.org> wrote:
> 2007/12/29, Andrew WC Brown <omen.king at gmail.com>:
> > I just see these large blocks of:
> > @shopping_list.should_receive(:milk)..and_return('milk')
> > @shopping_list.should_receive(:bagel).and_return('bagel')
> > @shopping_list.should_receive(:coffee).and_return('coffee')
> > and it would be much clearer if I could list them in a hash instead.
> What about :
> :milk => 'milk',
> :bagel => 'bagel',
> :coffee => 'coffee'
> }.each do |method, value|
> So it doesn't need a #should_receive_the_following method.
You can certainly do that (and I have), but again, you'd lose the
benefit of a unique line number in the failure message.
This is something that is often lost under the banner of DRY. DRY
doesn't mean "type as few characters as you can." It means don't
repeat functionality or knowledge within a system. IMO, multiple calls
to the same methods, but with different data, are NOT duplication in
More information about the rspec-users