[rspec-users] Do you think it would look cleaner?

Jean-François Trân jftran at rubyfrance.org
Sun Dec 30 03:52:04 EST 2007

2007/12/29, Andrew WC Brown <omen.king at gmail.com>:

> I just see these large blocks of:
> @shopping_list.should_receive(:milk)..and_return('milk')
>  @shopping_list.should_receive(:bagel).and_return('bagel')
> @shopping_list.should_receive(:coffee).and_return('coffee')
> and it would be much clearer if I could list them in a hash instead.

What about :

  :milk => 'milk',
  :bagel => 'bagel',
  :coffee => 'coffee'
}.each do |method, value|

So it doesn't need a #should_receive_the_following method.

   -- Jean-François.

More information about the rspec-users mailing list