[rspec-users] rSpec troubles

Michael Riley wdperson at hotmail.com
Sun Dec 16 11:47:13 EST 2007


David,

    Thanks for the reply.  I really appreciate it.  You must be updating the site as I was looking at it earlier the title said 1.0.8 and now the title says 1.1.0.  I have it running now.  So, I am back to my first step which is getting rSpec to work.  I ruined it yesterday trying to get autotest to work.  I must have had incompatible versions of rSpec and rSpec on Rails.  I was under the assumption that the 2 were different.  In other words rSpec works for any type of ruby app and rSpec on Rails works is specific to rails (fine tuned to Rails).  I see now that they are dependent.  What I did was removed the spec directory, the rSpec on Rails and rSpec directories in my vendor folder in my application.  Then installed both versions using the instructions under "Living on the edge."  Then ran the ruby script/generate rspec command.  Then created a rspec_model and ran the ruby script/spec spec command and everything worked great.  I appreciate the push in the right direction.  I'm going to try and get autotest to work now.

thanks.
Mike Riley

> Date: Sun, 16 Dec 2007 10:22:22 -0600
> From: dchelimsky at gmail.com
> To: rspec-users at rubyforge.org
> Subject: Re: [rspec-users] rSpec troubles
> 
> On Dec 16, 2007 10:15 AM, Michael Riley <wdperson at hotmail.com> wrote:
> >
> > Hello All,
> >
> >     I am hoping someone can help me.  I am having a nightmare of a time
> > trying to get rSpec to work.  It was working at one time, but I tried
> > installing Zentest to get autotest to work with rSpec and it's been downhill
> > ever since.  Here are the gems I have installed in my rails app:
> >
> > ZenTest 3.6.1 if it matters (technically this is in my Ruby gems list and
> > not in my vendor directory of my rails app).
> > Rails - version 2.0.1
> > rSpec on Rails (revision 3166).  Fixed one error by finding that you must
> > use the latest version with edge rails.
> >
> > The current error I am getting is:
> > custom_require.rb:27 in 'gem_original_require': no such file to load --
> > spec/example/configuration (MissingSourceFile)
> >
> > Wouldn't rSpec install all the necessary files or am I missing another gem?
> 
> Did you follow these installation instructions?
> 
> http://rspec.info/documentation/rails/install.html
> 
> You should have the same revision of rspec and rspec_on_rails installed as gems.
> 
> >
> > thanks for any assistance.
> > Mike Riley
> >
> > ________________________________
> > Don't get caught with egg on your face. Play Chicktionary! Check it out!
> > _______________________________________________
> > rspec-users mailing list
> > rspec-users at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/rspec-users
> >
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users

_________________________________________________________________
i’m is proud to present Cause Effect, a series about real people making a difference.
http://im.live.com/Messenger/IM/MTV/?source=text_Cause_Effect
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rspec-users/attachments/20071216/e8571524/attachment.html 


More information about the rspec-users mailing list