[rspec-users] Upgrade to 1.0.8 broke Rake

Luis Lavena luislavena at gmail.com
Tue Aug 14 17:51:48 EDT 2007


A follow up...

On 8/14/07, Luis Lavena <luislavena at gmail.com> wrote:
> Hello Guys.
>
> I'm upgrading a project from 0.9.8 to 1.0.8, following this procedure:
>

First, is 0.9.4  :-)

>
> Now, when running rake, get the following error: superclass mismatch
> for class Annotation
>
> The following pastie shows the backtrace from rake (--trace)
>
> http://pastie.caboo.se/87713
>
>

It seems is that I missed rspec installed 'as gem' even I have in the
vendor/plugins for this application (and use the script/spec to run).

Doing "gem install rspec -v '1.0.8'" solves the problem...

Which shouldn't happen in the first place :P

-- 
Luis Lavena
Multimedia systems
-
Leaders are made, they are not born. They are made by hard effort,
which is the price which all of us must pay to achieve any goal that
is worthwhile.
Vince Lombardi


More information about the rspec-users mailing list