[rspec-users] rspec with autotest on a windows machine

David Parker nemo7467 at gmail.com
Wed Aug 8 19:12:32 EDT 2007


Yes, my spec.opts file contains the following:

Thoughts?  If this seems like too much of a hassle, or unknown, I should say
that I plan on "upgrading" my windows machine to Ubuntu Linux in the next
week or two...


David Parker

>Do you have spec/spec.opts?

On Aug 8, 2007, at 5:25 PM, David Parker wrote:

> Hello all,
> I'm new to rSpec but after reading a couple of tutorials I've
> become enamored.  Anyway, I am at minute 42 of the rSpec basics
> screencast ( peepcode.com) and I'm having the following error
> running autotest w/rSpec:
> D:\ruby\projects\forecaster
> >autotest
> loading autotest/rails_rspec
> c:\ruby\bin\ruby -rrubygems -e "require 'redgreen'"  -S script/spec
> -O spec/spec.opts  spec/models/weather_spec.rb spec/views/weathers/
> show.rhtml_spec.rb spec/controllers/weathers_controller_spec.rb
> spec/views/weathers/new.rhtml_spec.rb spec/views/weathers/
> edit.rhtml_spec.rb spec/helpers/weathers_helper_spec.rb spec/views/
> weathers/index.rhtml_spec.rb
> invalid option: -O
> Test::Unit automatic runner.
> I also have the TDD screencast and I am able to run autotest with
> no problems:
> D:\ruby\projects\journal_app>autotest
> loading autotest/rails
> c:\ruby\bin\ruby -rrubygems -e "require 'redgreen'"  -I.;lib;test -
> rtest/unit -e "%w[test/functional/journals_controller_test.rb test/
> integration/journal_stories_test.rb test/unit/journal_test.rb].each
> { |f| require f }" | unit_diff -u
> Loaded suite -e
> Started
> ................
> Finished in 1.265 seconds.
> 16 tests, 33 assertions, 0 failures, 0 errors
> Note: I am running Rails 1.2.3 and ZenTest v 3.6.1 on a Windows
> machine (sad, I know, but we've discussed that already).
> When I run 'ruby script/spec -v' it says:
> RSpec-1.0.5 (r2081) - BDD for Ruby
> I've also tried installing the newest version of the rSpec plugins
> and running "ruby script/generate rspec" so the proper files are
> copied to the script folder.
> as a "hack" fix, I did this:
> 1) I removed my .autotest file completely (so no fun red/green/etc)
> 2) I modified plugins>rspec >lib>autotest> rspec.rb and removed "#
> {add_options_if_present}" from line 50
> Anyone know of what my problem may be?  Windows perhaps?  It would
> sure be nice to be able to keep my .autotest file...
> Thanks for any help you can provide!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/rspec-users/attachments/20070808/962a6026/attachment.html 

More information about the rspec-users mailing list