[Rspec-users] Usage Error

Rich Collins richcollins at gmail.com
Fri Oct 20 22:53:25 EDT 2006

rake spec seems to work fine, but I keep getting a usage error at the  
end of the spec run:

/usr/local/bin/ruby -I"/usr/local/lib/ruby/gems/1.8/gems/rspec-0.6.4/ 
lib" "/usr/local/lib/ruby/gems/1.8/gems/rspec-0.6.4/bin/spec"
Usage: spec [options] (FILE|DIRECTORY|GLOB)+

         --diff                       Show unified diff of Strings  
that are expected to be equal when they are not
     -c, --colour, --color            Show coloured (red/green) output
     -s, --spec SPECIFICATION_NAME    Execute a single specification
     -f, --format FORMAT              Builtin formats: specdoc|s|rdoc| 
                                      You can also specify a custom  
formatter class
                                      (in which case you should also  
specify --require)
     -r, --require FILE               Require FILE before running specs
                                      Useful for loading custom  
formatters or other extensions
     -b, --backtrace                  Output full backtrace
     -d, --dry-run                    Don't execute specs
     -v, --version                    Show version
     -h, --help                       You're looking at it

The noise is a bit annoying and may interfere with commit hooks for  
my repo

More information about the Rspec-users mailing list