[rspec-users] [ANN] RSpec 0.7.3

David Chelimsky dchelimsky at gmail.com
Sat Nov 25 01:03:56 EST 2006


I'm not sure what the problem is here. I'm able to run the specs in
the sample app (which includes a database and fixtures) against 1.1.6,
1.2.0 and edge (as of 5623).

I'm running on a mac w/ ruby 1.8.4. You?

On 11/24/06, s.ross <cwdinfo at gmail.com> wrote:
> Running with a fresh install of rSpec 0.7.3 and fresh install of edge
> rails, I still have the problem with "can't convert nil into a
> string." The problem seems to be that when you get to load_fixtures (/
> vendor/rails/activerecord/lib/active_record/fixtures.rb [580]),
> fixture_path is nil. I see where it is explicitly being set in
> spec_helper.rb (note to all, if you upgrade to 0.7.3, you will have
> to create a new spec_helper.rb and migrate any customizations), but
> that is apparently being overridden somewhere later in the chain.
>
> Any thoughts how best to get this working?
>
> Thanks,
>
> s.ross
>
>
> On Nov 24, 2006, at 5:25 PM, David Chelimsky wrote:
>
> > Hi all,
> >
> > I just released RSpec 0.7.3. It's got a few bug fixes and the rails
> > plugin *should* run against both Rails 1.1.6 and 1.2.0-RC1.
> >
> > If you run into problems, please report bugs and feature requests in
> > the tracker at rubyforge:
> >
> > http://rubyforge.org/tracker/?group_id=797
> >
> > Cheers,
> > David
> > _______________________________________________
> > rspec-users mailing list
> > rspec-users at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/rspec-users
>
> _______________________________________________
> rspec-users mailing list
> rspec-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-users
>


More information about the rspec-users mailing list