[rspec-users] running 0.6.4 and 0.7.0 side-by-side

Brandon Keepers bkeepers at gmail.com
Wed Nov 8 10:12:20 EST 2006

For those trying to move projects to 0.7.0, but still using 0.6.4,  
RubyGems supports this arcane syntax for the bin stubs that allow you  
to specify a gem version:

	spec _0.6.4_ /path/to/your/specs

And for the ruby on rails plugin, you can make "rake spec" work by  
add the following two lines to the top of tasks/rspec.rake file:

	require 'rubygems'
	require_gem 'rspec', '0.6.4'

Hope that helps,

More information about the rspec-users mailing list