[rspec-devel] Error when running Spec:Rails

David Chelimsky dchelimsky at gmail.com
Tue Sep 30 11:47:51 EDT 2008


On Tue, Sep 30, 2008 at 10:45 AM, Lian Liming <lianliming at gmail.com> wrote:
> Hi all,
>
> I am trying to use Spec:Rails, when running "rake spec", I got following error:
>
> /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.0/lib/active_support/core_ext/module/aliasing.rb:31:in
> `alias_method': undefined method `evaluate_value_proc' for class
> `Spec::Matchers::Change' (NameError)
>        from /usr/lib/ruby/gems/1.8/gems/activesupport-2.1.0/lib/active_support/core_ext/module/aliasing.rb:31:in
> `alias_method_chain'
>        from /home/data/projects/MicroBlogging/linkey/vendor/plugins/rspec-rails/lib/spec/rails/matchers/change.rb:8
> .........(omit the rest of error msg)
>
>
> I am using Rails 2.1.0 and rspec 1.1.5, and following the installation
> guide on http://github.com/dchelimsky/rspec-rails/wikis

You don't have compatible versions of rspec and rspec-rails. Make sure
you either get the versions tagged 1.1.5 of both, or that you have the
latest of both.

>
> Any possible wrong? Any help is appreciated and thanks in advance!
>
> Liming
> _______________________________________________
> rspec-devel mailing list
> rspec-devel at rubyforge.org
> http://rubyforge.org/mailman/listinfo/rspec-devel
>


More information about the rspec-devel mailing list