[rspec-devel] Issues with submodules in rspec-dev

David Chelimsky dchelimsky at gmail.com
Thu Apr 10 08:46:14 EDT 2008


On Thu, Apr 10, 2008 at 8:06 AM, Kyle Hargraves <philodespotos at gmail.com> wrote:
> On Thu, Apr 10, 2008 at 2:46 AM, Brian Takita <brian.takita at gmail.com> wrote:
>  > Hello,
>  >
>  >  I followed the directions at
>  >  http://github.com/dchelimsky/rspec-dev/wikis/contributingpatches
>  >  to initialize and update the submodules in the rspec-dev repo.
>  >
>  >  However, when I run git submodule update, I get:
>  >  btakita at btakita-laptop:~/workspace/rspec-dev$ git submodule init
>  >  btakita at btakita-laptop:~/workspace/rspec-dev$ git submodule update
>  >  fatal: Needed a single revision
>  >  Unable to find current revision in submodule path 'RSpec.tmbundle'
>  >
>  >  Has anybody seen this?
>
>  What version of git are you using?
>
>  1.5.4.5 works here

Yes - I know that git-submodule is a relatively recent addition and
that it has changed over the last couple of versions. I'm running
1.5.4 and just started clean (per the instructions) and all is well.

I'll update the docs.

> but I suspect the problem might be that the
>  RSpec.tmbundle directory exists when you clone the project, and the
>  submodule update then attempts to read the revision in the path, which
>  of course does not yet exist. rm -rf RSpec.tmbundle and try again,
>  maybe?
>
>
>
>  k
>  _______________________________________________
>  rspec-devel mailing list
>  rspec-devel at rubyforge.org
>  http://rubyforge.org/mailman/listinfo/rspec-devel
>


More information about the rspec-devel mailing list