[rspec-devel] [ rspec-Bugs-14166 ] Cannot build trunk

Edvard Majakari edvard at majakari.net
Sun Sep 23 15:42:08 EDT 2007


> On windows (vista), I can't seem to successfully check out the project.  When I execute:
> svn co svn://rubyforge.org/var/svn/rspec/trunk
> I get the following error part-way through the checkout:
> svn: In directory 'trunk\RSpec.tmbundle\Preferences'
> svn: Can't move 'trunk\RSpec.tmbundle\Preferences\.svn\tmp\Symbol List: Behaviour.tmPreferences.tmp.tmp' to 'trunk\RSpec.tmbundle\Preferences\.svn\tmp\Symbol List: Behaviour.tmPreferences.tmp': The parameter is incorrect.

This bug is present in Windows XP (and my guess is in any Windows version) as 
well. I think the problem is in colon ':' in the tmp file name - I ran into 
the exactly same problem in RailsConfEurope when I tried to retrieve the trunk
using both command line SVN and TortoiseSvn (using Windows XP, because the 
wireless network adapter doesn't work in Linux).

Sorry, I don't have solution for your problem but just wanted to confirm the 
bug. Is the offending file mandatory file in SVN, or is it a by-product and as
such removable?


More information about the rspec-devel mailing list