[rspec-devel] [ rspec-Bugs-14543 ] rspec_scaffold broken with Rails 2.0

noreply at rubyforge.org noreply at rubyforge.org
Mon Oct 15 11:36:50 EDT 2007


Bugs item #14543, was opened at 2007-10-08 13:22
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=14543&group_id=797

Category: None
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Steven Garcia (pimpmaster)
Assigned to: Nobody (None)
Summary: rspec_scaffold broken with Rails 2.0

Initial Comment:
Rails Edge r7774
Rspec Trunk r2701

Trying to run:

script/generate rspec_scaffold Thing

and I get

uninitialized constant Rails::VERSION::String

----------------------------------------------------------------------

Comment By: Spencer Turner (spencer)
Date: 2007-10-15 16:36

Message:
I get the same thing (Also on OS X 10.4.10)

same error if I run from script/console:

However, Rails:VERSION:STRING returns a value.

Line 40 in rspec_scaffold_generator.rb should be:
    if Rails::VERSION::STRING =~ /^1\.2\.[123]/
not
    if Rails::VERSION::String =~ /^1\.2\.[123]/

confirmed working after that change on 1.2.5

Sorry, probably not the right format to submit this in

I'll read up on a more formal submission.



----------------------------------------------------------------------

Comment By: Steven Garcia (pimpmaster)
Date: 2007-10-08 13:23

Message:
BTW, this is on OS 10.4.10

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=14543&group_id=797


More information about the rspec-devel mailing list