[rspec-devel] [ rspec-Bugs-14406 ] rake spec:plugins:rspec_on_rails fails with Rails 2.0 preview release

noreply at rubyforge.org noreply at rubyforge.org
Wed Oct 3 14:09:43 EDT 2007


Bugs item #14406, was opened at 2007-10-03 10:30
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=14406&group_id=797

Category: rails plugin
Group: None
>Status: Open
Resolution: Accepted
Priority: 3
Submitted By: Neil Wilson (aldursys)
Assigned to: David Chelimsky (dchelimsky)
Summary: rake spec:plugins:rspec_on_rails fails with Rails 2.0 preview release

Initial Comment:
File helper_spec_spec.rb still contains ActionView::Helpers::JavascriptMacrosHelper and ActionView::Helpers::PaginationHelper. 

Once you comment these out (which I'm sure isn't the correct fix), then you get failures due to a lack of fixtures.

Is it worth removing this task in Rake until you get the specs working?



----------------------------------------------------------------------

>Comment By: Neil Wilson (aldursys)
Date: 2007-10-03 18:09

Message:
r2691 still can't find the fixtures specified in 
helper_spec_spec.rb when the Rake task is run from an 
arbitrary Rails app.




----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2007-10-03 14:56

Message:
Forgot to close this.

----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2007-10-03 14:04

Message:
Absolutely not. Better to fix the problem than hide it, don't you think.

Resolved in r2691, which now passes against rails 1.2.1, 1.2.2, 1.2.3, 2.0.0 preview, and edge

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=14406&group_id=797


More information about the rspec-devel mailing list