[rspec-devel] [ rspec-Bugs-14406 ] rake spec:plugins:rspec_on_rails fails with Rails 2.0 preview release

noreply at rubyforge.org noreply at rubyforge.org
Sun Nov 18 23:32:52 EST 2007


Bugs item #14406, was opened at 2007-10-03 06:30
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=14406&group_id=797

Category: rails plugin
Group: None
Status: Open
Resolution: Accepted
Priority: 3
Submitted By: Neil Wilson (aldursys)
Assigned to: David Chelimsky (dchelimsky)
Summary: rake spec:plugins:rspec_on_rails fails with Rails 2.0 preview release

Initial Comment:
File helper_spec_spec.rb still contains ActionView::Helpers::JavascriptMacrosHelper and ActionView::Helpers::PaginationHelper. 

Once you comment these out (which I'm sure isn't the correct fix), then you get failures due to a lack of fixtures.

Is it worth removing this task in Rake until you get the specs working?



----------------------------------------------------------------------

Comment By: Chad Humphries (spicycode)
Date: 2007-11-18 23:32

Message:
Moved to http://rspec.lighthouseapp.com/projects/5645-rspec/tickets/70-14406-rake-spec-plugins-rspec_on_rails-fails-with-rails-2-0-preview-release#ticket-70-2

----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2007-10-31 08:39

Message:
OK - I've really resolved the first problem (trying to load helpers that don't exist). I had gotten it to work in rspec's pre_commit process based on env vars that get set during that process. Obviously that doesn't help when another app is using the plugin.

The problem of fixtures remains, but I see the path. Should have this fixed soon.

----------------------------------------------------------------------

Comment By: Neil Wilson (aldursys)
Date: 2007-10-03 14:09

Message:
r2691 still can't find the fixtures specified in 
helper_spec_spec.rb when the Rake task is run from an 
arbitrary Rails app.




----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2007-10-03 10:56

Message:
Forgot to close this.

----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2007-10-03 10:04

Message:
Absolutely not. Better to fix the problem than hide it, don't you think.

Resolved in r2691, which now passes against rails 1.2.1, 1.2.2, 1.2.3, 2.0.0 preview, and edge

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=14406&group_id=797


More information about the rspec-devel mailing list