[rspec-devel] [ rspec-Bugs-15584 ] Rspec Build Fails with rails 1.2.4

noreply at rubyforge.org noreply at rubyforge.org
Mon Nov 12 12:13:24 EST 2007


Bugs item #15584, was opened at 2007-11-12 16:44
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=15584&group_id=797

Category: None
Group: None
Status: Closed
Resolution: Rejected
Priority: 3
Submitted By: Scott Taylor (smtlaissezfaire)
Assigned to: Nobody (None)
Summary: Rspec Build Fails with rails 1.2.4

Initial Comment:

With a brand new trunk with no changes (at revision 2879), rake pre_commit fails when building rails 1.2.4.  Here is the error message that I'm getting (with  cd example_rails_app/; rake -f Multirails.rake pre_commit --trace):

#####################################################
running pre_commit against rails 1.2.4
#####################################################
#####################################################
Removing generated files:
#####################################################
#####################################################
Migrating down and reverting config/routes.rb
#####################################################
rake aborted!
no such file to load -- /Users/smt/play/rspec/example_rails_app/vendor/rails/1.2.4/railties/lib/initializer
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
/Users/smt/play/rspec/example_rails_app/config/boot.rb:27
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `gem_original_require'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
/Users/smt/play/rspec/example_rails_app/rakefile:4
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1940:in `load'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1940:in `raw_load_rakefile'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1727:in `load_rakefile'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in `standard_exception_handling'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1726:in `load_rakefile'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1710:in `run'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in `standard_exception_handling'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1708:in `run'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/bin/rake:7
/usr/local/bin/rake:16:in `load'
/usr/local/bin/rake:16
(in /Users/smt/play/rspec/example_rails_app)
running against rails 1.2.4
rake aborted!
ERROR while running rake: rake db:migrate VERSION=4 --trace
/Users/smt/play/rspec/pre_commit/lib/pre_commit/pre_commit.rb:19:in `rake_sh'
/Users/smt/play/rspec/pre_commit/lib/pre_commit/rspec_on_rails.rb:169:in `migrate_down'
/Users/smt/play/rspec/pre_commit/lib/pre_commit/rspec_on_rails.rb:158:in `destroy_purchase'
/Users/smt/play/rspec/pre_commit/lib/pre_commit/rspec_on_rails.rb:49:in `cleanup'
/Users/smt/play/rspec/pre_commit/lib/pre_commit/rspec_on_rails.rb:32:in `rspec_pre_commit'
/Users/smt/play/rspec/pre_commit/lib/pre_commit/rspec_on_rails.rb:9:in `pre_commit'
/Users/smt/play/rspec/pre_commit/lib/pre_commit/rspec_on_rails.rb:6:in `each'
/Users/smt/play/rspec/pre_commit/lib/pre_commit/rspec_on_rails.rb:6:in `pre_commit'
/Users/smt/play/rspec/example_rails_app/Multirails.rake:7
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in `call'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in `execute'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:392:in `execute'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:362:in `invoke'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in `synchronize'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:355:in `invoke'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:in `top_level'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1739:in `top_level'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in `standard_exception_handling'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1733:in `top_level'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1711:in `run'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1761:in `standard_exception_handling'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/lib/rake.rb:1708:in `run'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.3/bin/rake:7
/usr/local/bin/rake:16:in `load'
/usr/local/bin/rake:16


I've tried this both with mysql and the sqlite3 in memory database.  Both return the same error.



----------------------------------------------------------------------

>Comment By: Scott Taylor (smtlaissezfaire)
Date: 2007-11-12 17:13

Message:
David: My thoughts exactly.


----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2007-11-12 17:00

Message:
Closed per poster request.

----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2007-11-12 16:59

Message:
I've been thinking we shouldn't really support 1.2.4 anyway. It was out for a day or two, and was quickly followed up by 1.2.5, which was immediately recommended for anyone who had upgraded to 1.2.4.

WDYT?

----------------------------------------------------------------------

Comment By: Scott Taylor (smtlaissezfaire)
Date: 2007-11-12 16:56

Message:
Close this one, too.  It was just me being stupid.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=15584&group_id=797


More information about the rspec-devel mailing list