[rspec-devel] [ rspec-Bugs-11247 ] standalone autotest doesn't work because of unneeded autotest.rb

noreply at rubyforge.org noreply at rubyforge.org
Thu May 31 06:38:48 EDT 2007


Bugs item #11247, was opened at 2007-05-31 05:52
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=11247&group_id=797

Category: None
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Mikko Lehtonen (scoopr)
Assigned to: Nobody (None)
Summary: standalone autotest doesn't work because of unneeded autotest.rb

Initial Comment:

there is  $RSPECDIR/lib/autotest.rb which is completely unneeded as far as I can see, but interferes with autotest.

More specifially, lib/autotest/rspec.rb  requires 'autotest' (and expects to get zentest's Autotest class) but gets that dummy file instead.

Everything works for me when I rename/remove that file.
 

----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2007-05-31 10:38

Message:
Before investigating this we need to know the versions of all 
relevant software you are using, for example:

* OS X 10.4.9
* Ruby 1.8.6
* RSpec 1.8.2 or RSpec trunk r1643
* Spec::Rails 1.8.2 or Spec::Rails tag r1234...
* Rails 1.2.3 or Rails edge r5645
* Whatever other relevant software.

Without this information it's like solving 1 equation (your 
question) with 5 unknown variables (the versions).

We strongly recommend that you use the latest released version of
RSpec, alternatively the subversion trunk (if you're the bleeding
edge kind of person).

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=11247&group_id=797


More information about the rspec-devel mailing list