[rspec-devel] [ rspec-Feature Requests-10697 ] Consider renaming 'describe' method to 'behaviour'

noreply at rubyforge.org noreply at rubyforge.org
Wed May 9 04:13:18 EDT 2007


Feature Requests item #10697, was opened at 2007-05-08 19:00
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3152&aid=10697&group_id=797

Category: None
Group: None
Status: Open
Priority: 3
Submitted By: Brian Takita (btakita)
Assigned to: Nobody (None)
Summary: Consider renaming 'describe' method to 'behaviour'

Initial Comment:
It would be conducive to conversations if I didn't need to do a mental mapping from describe to behaviour.


----------------------------------------------------------------------

Comment By: Michael Klishin (michaelklishin)
Date: 2007-05-09 08:13

Message:
Brian,

I think 3rd alias for one method will be too confusing for newcomers. Especially for those who start from 0.9.x but still see 0.8.x tutorials.

----------------------------------------------------------------------

Comment By: Brian Takita (btakita)
Date: 2007-05-09 07:38

Message:
I do have to say that the new syntax encourages me to
mention Behaviour more than the old syntax.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3152&aid=10697&group_id=797


More information about the rspec-devel mailing list