[rspec-devel] [ rspec-Bugs-10529 ] have_tag does not work while assert_select does

noreply at rubyforge.org noreply at rubyforge.org
Thu May 3 11:17:44 EDT 2007


Bugs item #10529, was opened at 2007-05-02 16:46
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=10529&group_id=797

Category: rails plugin
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Jason Roelofs (jameskilton)
Assigned to: Nobody (None)
Summary: have_tag does not work while assert_select does

Initial Comment:
I cannot get the development environment setup and thus I cannot run the attached patch against SVN trunk, so if this doesn't die for anyone then I'll check my environment, but this is the exact code that is causing problems in my rails app. 

Basically, I pass in the exact same options to have_tag as I do to assert_select. assert_select passes perfectly while have_tag fails.

My environment:

Ruby version                 1.8.6 (i386-mswin32)
RubyGems version             0.9.2
Rails version                1.2.0
Active Record version        1.14.4
Action Pack version          1.12.5
Action Web Service version   1.1.6
Action Mailer version        1.2.5
Active Support version       1.3.1
Edge Rails revision          6494
Application root             C:/Development/AdminPortal
Environment                  development
Database adapter             mysql

----------------------------------------------------------------------

>Comment By: Aslak Hellesøy (aslak_hellesoy)
Date: 2007-05-03 11:17

Message:
Running the spec with --backtrace and posting the backtrace here might help

----------------------------------------------------------------------

Comment By: Jason Roelofs (jameskilton)
Date: 2007-05-03 09:57

Message:
So it looks like this is in fact a windows problem. I just
ran the tests in two different Rails environments (1.2.3 and
Edge 6494) on Linux and they both pass. I'll start delving
deeper into what could be the problem when I have time. 

----------------------------------------------------------------------

Comment By: David Chelimsky (dchelimsky)
Date: 2007-05-02 21:16

Message:
Everything's passing against ruby 1.8.5 and 1.8.6 as well. Aslak and I are both running on Macs, so perhaps this is a win-ruby problem. Is there anybody else who is having this problem on windows?

----------------------------------------------------------------------

Comment By: Aslak Hellesøy (aslak_hellesoy)
Date: 2007-05-02 20:56

Message:
I applied and committed the patch (r1892) with one minor modification:

describe "have_tag", :behaviour_type => :controller do

(This is needed in the plugin's specs because it cannot be inferred from its location)

It passes fine for me for Railses (edge r, 1.1.6, 1.2.1, 1.2.2, 1.2.3)  and Ruby 1.8.4 (about time I upgrade my Ruby, but I'm lazy)

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3149&aid=10529&group_id=797


More information about the rspec-devel mailing list