[rspec-devel] [ rspec-Feature Requests-10516 ] should_include should be able to accept multiple items

noreply at rubyforge.org noreply at rubyforge.org
Wed May 2 07:48:45 EDT 2007


Feature Requests item #10516, was opened at 2007-05-02 04:21
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3152&aid=10516&group_id=797

Category: expectation module
Group: None
Status: Open
Priority: 3
Submitted By: Sharon Rosner (ciconia)
Assigned to: Nobody (None)
Summary: should_include should be able to accept multiple items

Initial Comment:
example:

specify "permissions should reflect those granted" do
  @user.grant(@root, true, true, true)
  @user.permissions(@root).should_include(:read, :write, :execute)
end


----------------------------------------------------------------------

>Comment By: Aslak Hellesøy (aslak_hellesoy)
Date: 2007-05-02 07:48

Message:
Sorry, I was a little quick on the trigger here. We should be able to implement the include matcher with varargs as you ask - good idea!. 

No need to provide the version info I asked about :-)

----------------------------------------------------------------------

Comment By: Aslak Hellesøy (aslak_hellesoy)
Date: 2007-05-02 04:38

Message:
Before investigating this we need to know the versions of all 
relevant software you are using, for example:

* OS X 10.4.9
* Ruby 1.8.6
* RSpec 1.8.2 or RSpec trunk r1643
* Spec::Rails 1.8.2 or Spec::Rails tag r1234...
* Rails 1.2.3 or Rails edge r5645
* Whatever other relevant software.

Without this information it's like solving 1 equation (your 
question) with 5 unknown variables (the versions).

We strongly recommend that you use the latest released version of
RSpec, alternatively the subversion trunk (if you're the bleeding
edge kind of person).

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=3152&aid=10516&group_id=797


More information about the rspec-devel mailing list